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Introduction
DocMate
DocMate® compares thousands of document files in multiple directories and
subdirectories to determine which files are the most highly correlated. DocMate
compares any kinds of documents, comparing text content and text metadata. DocMate
can be used to significantly speed up the work of finding plagiarism, because it can
direct the examiner to look closely at a small amount of text in a handful of files rather
than thousands of combinations. DocMate is also useful for determining common
authorship of two different documents.
DocMate compares every file in one directory with every file in another directory,
including all subdirectories if requested. The full version of DocMate produces a
database that can then be exported to an HTML report that lists the most highly
correlated pairs of files. The LT version of DocMate directly creates the HTML report.
You can click on any particular pair listed in the HTML basic report see an HTML
detailed report that shows the specific text in the files that caused the high correlation.
The full version of DocMate allows searching the Internet for all references to matching
words found in a DocMate database. This feature is used to determine whether words
found in two sets of files are commonly used or not, depending on how many references
can be found on the Internet.
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Copyrights, Trademarks, Patents
Copyrights
The materials in this users guide are copyright 2009-2017 by Software Analysis and
Forensic Engineering Corporation.
All written materials from SAFE Corporation regarding DocMate and SourceDetective,
including the material in this User's Guide and the source code for all versions of
DocMate and SourceDetective are the copyright of SAFE Corporation.

Trademarks
SAFE Corporation, the SAFE Corporation logo, the SAFE Corporation brand, DocMate,
the DocMate logo, and all other SAFE Corporation product names referenced herein
are registered trademarks or trademarks of SAFE Corporation. All other brand and
product names mentioned herein are trademarks of their respective owners.

2

Using DocMate
System Requirements
DocMate will run on any computer using any of the following versions of the Microsoft
Windows operating system
• Windows 2000
• Windows XP
• Windows Vista
• Windows 7
• Windows 8
• Windows 10
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Licenses
Licenses must be purchased from SAFE Corporation. Some functions of DocMate, such
as generating HTML reports and statistics spreadsheets, do not require a license.
To request licenses, open the authorization form shown below from the Help menu.
Send the site code to SAFE Corporation and the number or type of licenses requested,
along with appropriate payment. SAFE Corporation will send back an Authorization Key
that must be entered into the field in the form. Press the Apply Authorization button.
Licenses are enabled for only one PC and cannot be transferred to another PC.

Feature Set
The feature set can be one of two types.
•
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Full version. All features are enabled. Comparing two file sets creates a
database that can be filtered and from which HTML reports and spreadsheets
can be generated.

CodeMatch
•

LT version. Comparing two file sets creates an HTML report. All other features
are disabled.

License Type
The license can be one of three types.
•
•

•

File size based. Used to examine a fixed amount of bytes of text. Licenses are
used up as text is examined. Internet searches also use up licenses.
Time based. Used to examine any amount of text for a fixed number of days.
Note that there is still a limit to the number of Internet searches that can be
performed. If that limit is reached, no more searching can be done for the
remainder of the license term unless a new license is purchased.
Unlimited. There is no limit on the number of megabytes of text that can be
examined and there is no expiration date.

Licenses Allocated and Licenses Remaining
These fields indicate the number of licenses that were originally allocated and how
many unused licenses remain. These fields are valid only for a megabyte based license.
For other licenses, the fields are not applicable ("n/a").

Days Allocated and Days Remaining
These fields indicate the number of days that were originally allocated for the license
and how many days remain on the license. These fields are valid only for a time based
license. For other licenses, the fields are not applicable ("n/a").
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The Menu
The DocMate menu is described below.

File Menu
The following selections are found on the File menu.
File->Compare
This menu selection runs a comparison on the document files specified on the main
screen using the parameters specified there. For the full version of DocMate, the result
is a database that can be filtered and from which HTML reports and spreadsheets can
be generated. For the LT version of DocMate, the result is an HTML report.
File->Exit
This menu selection causes the program to exit.

Tools Menu
The following selections are found on the Tools menu. The Tools menu is disabled for
the LT version of DocMate.
Tools->Report
This menu selection creates an HTML report from the DocMate database that gives the
comparison results in an easy-to-read format.
Tools->Search
This menu selection searches the Internet for words that match in both sets of
documents, and puts the resulting number of hits into the DocMate database.
This feature considers each word in the DocMate database and searches the Internet
for references to each one. The number of times a word is found in the search is then
inserted into a new copy of the database, leaving the original database intact.
Spreadsheets can then be generated to show the number of "hits" for each word. For
more information, see the section entitled Search Spreadsheets.
Tools->Spreadsheets->Distribution
This menu selection creates a distribution spreadsheet from the DocMate database that
shows the distribution of correlations between document files.
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Tools->Spreadsheets->Search
This menu selection creates a search spreadsheet from the DocMate database that
shows the number of Internet hits for each word in the database.
Tools->Spreadsheets->Summary
This menu selection creates a summary spreadsheet from the DocMate database that
shows a summary of all correlations between document files.

Help Menu
The following selections are found on the Help menu.
Help->About
This menu selection gives the version number and other information about DocMate.
Help->Instructions
This menu selection brings up this users guide.
Help->License
This menu selection brings up the authorization form for entering licenses to enable the
various tools. See the section entitled Licenses for more information.
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Running DocMate
DocMate compares files using a set of algorithms to determine their correlation. Below
is a screen shot of the DocMate form. Following that are step-by-step instructions for
running DocMate.

Step 1
Select the first folder for comparison by clicking on the browse button or entering the
path in the text field. Check the box to include files in all subdirectories.

Step 2
Enter the files types in the first folder to compare. Separate multiple file types with a
semicolon. Use the * and ? wildcard characters if needed.

Step 3
Select the second folder for comparison by clicking on the browse button or entering the
path in the text field. Check the box to include files in all subdirectories.

Step 4
Enter the files types in the second folder to compare. Separate multiple file types with a
semicolon. Use the * and ? wildcard characters if needed.

Step 5
Select the reporting threshold from the pulldown menu. This determines how many files
are reported. DocMate reports only the most highly correlated files. By setting the
number of files to report to a large number you may get a very large database. By
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setting the number of files to report to a small number, the database will be smaller but
it may not include all the similar files that you would like to see.

Step 6
Choose whether to only compare files if they have the same name. This will speed up
the comparison significantly because far fewer combinations of files are compared.

Step 7
Select Compare from the File menu. The number of licenses, if any, that are required
for this run of DocMate will be shown. You will have the ability to cancel the DocMate
run at this point without using up licenses.
If you have licensed the full version, you will be then asked to name the database that
will be generated. To generate readable HTML reports from the database see the
section entitled Creating HTML Reports. If you have licensed the LT version, you will be
asked to name the HTML report that will be generated.
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DocMate Basic Report

DocMate Basic Report
Version: 1.0.0 | Date: 01/28/10 | Time: 11:33:11
SETTINGS | RESULTS | UNCOMPARED FILES | TOTALS
SETTINGS
Compare files in folder
File types

Z:\DocMate\files1
Including subdirectories
*.*

To files in folder

Z:\DocMate\files2
Including subdirectories

File types

*.doc;*.txt

Reporting file threshold

8 files

RESULTS
Z:\DocMate\files1\generic
lease1.doc
Score

10

Compared to file

100

Z:\DocMate\files2\generic lease.doc

76

Z:\DocMate\files2\SAFE Patent Policy.doc

57

Z:\DocMate\files2\SAFE PTO and Holiday Policy.doc

26

Z:\DocMate\files2\SAFE Network.doc

16

Z:\DocMate\files2\files\SAFE Network.doc

CodeMatch

Z:\DocMate\files1\SAFE
Network1.doc
Score

Compared to file

100

Z:\DocMate\files2\SAFE Network.doc

79

Z:\DocMate\files2\SAFE Patent Policy.doc

49

Z:\DocMate\files2\SAFE PTO and Holiday Policy.doc

26

Z:\DocMate\files2\generic lease.doc

Z:\DocMate\files1\SAFE Patent Policy1.doc
Score

Compared to file

100

Z:\DocMate\files2\SAFE PTO and Holiday Policy.doc

74

Z:\DocMate\files2\SAFE Patent Policy.doc

57

Z:\DocMate\files2\generic lease.doc

49

Z:\DocMate\files2\SAFE Network.doc

TOTALS
Total number of bytes in files in folder 1 = 216576
Total number of bytes in files in folder 2 = 216576
Total run time = 25 Seconds

DocMate copyright 2011 by Software Analysis and Forensic Engineering Corporation
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DocMate Detailed Report

DocMate Detailed Report
Version: 0.1.0 | Date: 02/26/11 | Time: 16:11:48

SCORE 73
SETTINGS
Compare file 1:

Z:\ DocMate\files1\SAFE Network1.doc

To file 2:

Z:\ DocMate\files1\SAFE Network1.doc

Links to results:

Matching Word Sequences
Matching Words
Partially Matching Words
Score

RESULTS
Matching Word Sequences
File1
Line#

File2
Line#

Number of
matching words

70

48

102
Content Types xml 3aZ rels rels !ky theme
theme themeManager xml theme theme theme1 xml YOo
toc UDb lAp pT0 jcs 3Vq TZaG y8I
IqbJ caS dDA AGm OMf XF64 8fi BiD
N!V MN9 eBo 4vfa theme theme rels themeManager
xml rels QAs Content Types xmlPK rels relsPK
!ky theme theme themeManager xmlPK theme theme theme1
xmlPK theme theme rels themeManager xml relsPK xml
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version encoding UTF standalone yes clrMap xmlns http
schemas openxmlformats org drawingml 2006 main bg1 lt1
tx1 dk1 bg2 lt2 tx2 dk2 accent1 accent1
accent2 accent2 accent3 accent3 accent4 accent4 accent5 accent5
accent6 accent6 hlink hlink folHlink folHlink
674

176

16
Root Entry Data 1Table WordDocument SummaryInformation
DocumentSummaryInformation CompObj
Microsoft Office Word 2003 Document MSWordDoc Word
Document

Matching Words
1ky

1Table

2003

2006

3aZ

3Vq

4vfa

8fi

accent1

accent2

accent3

accent4

accen
t5

accent6

AGm

Arial

bg1

bg2

BiD

bjbj

Bob

Calibri

Cambria

caS

Char

clrMap

CompO
bj

Consulting

Conte
nt

Data

dDA

Defaul
t

dk1

dk2

Docum
ent

DocumentSummaryInfo
rmation

dotm

drawingml

eBo

encodi
ng

Entry

folHlin
k

Font

Heading

hlink

http

IqbJ

jcs

lAp

List

lt1

lt2

main

Math

Microsoft

MN9

MSWordD
oc

N!V

New

Normal

Offic
e

OMf

openxmlfor
mats

org

Paragraph

ph6

pT0

QAs

rels

relsPK

Roman

Root

SAFE

schema
s

standalo
ne

SummaryInformation

Symb
ol

Table

theme

theme
1

themeMan
ager

Times

Title

toc

tx1

tx2

Types

TZaG

UDb

Unkno
wn

UTF

version

Word

WordDocu
ment

XF64

xml
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xmlns

xmlPK

y8I

yes

YOo

Zeidman

Partially Matching Words
File1 Words
allowed

CONFIDENTIAL

Consulting7

Ethernet

OHtQODtiO9t

File2 Words
allowance

Corporation

filing

inventor

Patent

the

SCORE 73
DocMate copyright 2011 by Software Analysis and Forensic Engineering Corporation
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Running SourceDetective
SourceDetective considers each word in the DocMate database and searches the
Internet for references to each one. The number of times a word is found in the search
is then inserted into a new copy of the database, leaving the original database intact.
Spreadsheets can then be generated to show the number of "hits" for each word. For
more information, see the section entitled Search Spreadsheets.
Choose Tools->Search from the Menu. You will be asked for the existing DocMate
database to examine and the new DocMate database to create. The number of "hits"
will be inserted into the new database.
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Exporting databases
HTML reports
In the full version of DocMate, a database can be automatically turned into HTML
reports for easy reading and presentation of results. A basic report is generated that
shows file pairs and their correlation scores. By clicking on the score, a detailed HTML
report will come up. These detailed reports are kept in subfolders. The detailed reports
give more information about how the score was determined, showing specific
similarities or differences between the files. The file names are given at the top of the
report and include a hyperlink that, when clicked, allows the file to be brought up in a
viewer or editor. The back and next buttons on the detailed reports allow you to
navigate the detailed reports without going back to the basic report.
For information see the sections entitled DocMate Basic Report and DocMate Detailed
Report.
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Distribution Spreadsheets
In the full version of DocMate, a distribution spreadsheet can be generated that shows
the distribution of correlation scores among the two sets of files compared. It is
important to note that for each file in the first set of compared files, a distribution
spreadsheet only considers the correlation scores for the most correlated file in the
second set of files compared. So for each file in the first set of files, the spreadsheet will
only consider the most correlated file in the second set, even other less correlated files
are noted in the database. Also note that while each file in the first set of files is
considered exactly once, some files in the second set of files may be considered
multiple times or not at all.
Consider set A consisting of files A1 and A2. Consider set B consisting of files B1 and
B2. Now consider the table below of similarity scores. The file with the most similarity to
file A1 is file B1 and the file with the most similarity to file A2 is also file B1. So file B1
will be counted twice in the distribution spreadsheet.
Set A
File A1
File A1
File A2
File A2

Set B
File B1
File B2
File B1
File B2

Similarity Score
90
20
67
12

Choose Tools->Spreadsheets->Distribution from the Menu. You will be asked for the
existing DocMate database to examine and the new spreadsheet to create.

Example Distribution Spreadsheet
Below is an example of a spreadsheet created from a DocMate database.
A

B

C

D

1

DocMate Results Distribution

2

Database Analysis

3

Database

4

Run date

C:\SAFE Corporation\code
development\test\DocMate\results\DocMate1.cdb
12/1/2010

5

Analysis date

12/2/2010

Folder 1

C:\SAFE Corporation\code
development\test\DocMate\files1
including subdirectories

Folder 2

C:\SAFE Corporation\code
development\test\DocMate\files2

6
7
8
9

18

E

F

Exporting databases
10
11
12

File threshold

8

13

Score threshold

1

Total files in folder 1

16

14
15
16
17
18
19

File pair
comparisons
Correlation score

Folder 1
Number of
files
1

Folder 2

Number of
lines
5

Number of
bytes
252

Number of
lines
5

Number of
bytes
230

20

20

21

28

1

291

7725

227

5010

22

75

2

8

224

8

228

23

99

1

56

1997

52

1890

24

100

11

960

27288

960

27282

1320

37486

1252

34640

25
26

Totals

16

27

Total not fully
correlated
Percent not fully
correlated

5

28

31.25

The top line shows that the spreadsheet was created from a DocMate database. The
run date shows the date that DocMate was run while the analysis date shows the date
that the spreadsheet was created. The folders are the ones that were compared to
create the database.
The score threshold shows that files needed at least a correlation score of 1 to be
reported.
The total number of files in the first folder (including all subfolders if that was selected
for the analysis) is shown as 16.
Rows 18 and 19 are the table header. Column A shows a correlation score while
column B shows the total number of files. Columns C and D show the total number of
lines and bytes in files in folder 1 that had this particular score. Columns E and F show
the total number of lines and bytes in files in folder 2 that had this particular score. Note
that only the highest correlation score is considered for this analysis. In other words, if
file A in folder 1 is matched with a correlation score of 97 by file X in folder 2, a
correlation score of 93 by file Y in folder 2, and a correlation score of 37 by file Z in
folder 2, only file X in folder 2 is considered in the analysis.
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Search Spreadsheets
In the full version of DocMate, a search spreadsheet can be generated that shows the
number of times a word can be found when searching the Internet using
SourceDetective.
Choose Tools->Spreadsheets->Search from the Menu. You will be asked for the
existing DocMate database to examine and the new spreadsheet to create.

Example Search Spreadsheet
Below is an example of a spreadsheet created from a DocMate database.
A

B

1

DocMate Internet Search Results

2

Database Analysis

3

Database

4

Run date

5

Analysis date

12/2/2010

Folder 1

C:\SAFE Corporation\code
development\test\DocMate\files1
including subdirectories

Folder 2

C:\SAFE Corporation\code
development\test\DocMate\files2

12

Words

Search Score

13

apple

2147483647

14

banana

2147483647

15

boisterous

5

16

boys

29

17

caramel

37

18

envelope

100

19

few

155

20

jockey

398

21

mellow

1

22

melon

0

23

SAFE

0

24

Thomas,

226000000

25

restitution

57

C:\SAFE\code
development\test\DocMate\results\DocMate1.cdb
12/1/2010

6
7
8
9
10
11

20

Exporting databases
26

Zeidman

110000

The top line shows that the spreadsheet was created from a DocMate database. The
run date shows the date that DocMate was run while the analysis date shows the date
that the spreadsheet was created. The folders are the ones that were compared to
create the database.
The next line shows that this is a listing of words. The left column lists words in
alphabetical order. The right column gives the number of hits on the search engine for
this word.
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Summary Spreadsheet
In the full version of DocMate, a summary spreadsheet can be generated that shows
the summary of correlation scores among the two sets of files compared. Choose Tools>Spreadsheets->Summary from the Menu. You will be asked for the existing DocMate
database to examine and the new spreadsheet to create.

Example DocMate Spreadsheet
Below is an example of a spreadsheet created from a DocMate database.
1
2
3
4
5
6
7
8
9
10
11
12
13

A
B
DocMate Results Summary
Database Analysis
Run date
7/4/2010
Analysis date
8/1/2010
File threshold

4

Total files in folder 1
Total file pairs

22
83

Scores
Numbers
Percentage

C

D

E

F

(0-9)
17
20

(10-19)
15
18

(20-29)
26
31

(30-39)
21
25

G

(40-49)
0
0

H

(50-59)
4
5

The top line shows that the spreadsheet was created from a DocMate database. The
run date shows the date that DocMate was run while the analysis date shows the date
that the spreadsheet was created.
The threshold shows that the top four files that were correlated to the files in folder 1
were reported.
The total number of files in the first folder (including all subfolders if that was selected
for the DocMate run) is shown as 22. The total number of files pairs that are reported in
the database is 83.
Row 11 is the table header. Columns C through H show intervals of correlation scores.
For example column C represents correlation scores between 0 and 9 inclusively.
Row 12 shows the number of file pairs in each match score interval while row 13 shows
the percentage of file pairs in each match score interval.
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DocMate database format
SAFE Corporation wants third party developers to create software to analyze DocMate
database files and generate reports and statistics from them. In light of that desire,
below is an example of a DocMate database file with all sections explained by a
comment. Comments are lines beginning with a # symbol.

Tag Definitions
The DocMate database tags and their meanings are given in the table below.
Tag
#
<Program>
<Version>
<Date>
<Time>
<LComment>
<Describe>
<CComment>
<Filters>
</Filters>
<Folder1>
<Subs1>
<Folder2>
<Subs2>
<Language>
<FileType>
<SameName>
<Dirs>
<Algorithm>
<FileThresh>
<ScoreThresh>
<Filter>
<Dir1>
<Dir2>
<File1>
<NumWords1>
<Size1>
<File2>
<NumWords2>
<Size2>
<StatementScore>
<CommentScore>

Definition
First character in a comment
Program name
Program version
Date file was created
Time file was created
Left-justified comment to be placed in the output file
Insert program description
Right-justified comment to be placed in the output file
Beginning of filters used to create this database
End of filters used to create this database
Input folder 1
Compare subdirectories for folder 1? T or F
Input folder 2
Compare subdirectories for folder 2? T or F
Programming language
Filetype
Compare files of same name only? T or F
Compare directories? T or F
Algorithm name
File number threshold to report
Score threshold to report
Filter name
Input file 1 path relative to InFolder1
Input file 2 path relative to InFolder2
Input file 1 name
Number of words in file 1
Number of bytes in file 1
Input file 2 name
Number of words in file 2
Number of bytes in file 2
Statement match score
Comment match score
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<SequenceScore>
<IdentifierScore>
<SubIdentifierScore>
<Score>
<NoScore>
<Differences>
</Differences>
<Statements>
</Statements>
<Comments>
</Comments>
<Lines1>
<Lines2>
<Line>
<Sequences>
<InSeq>
<Instr>
</Sequences>
<IDs>
<ID>
</IDs>
<PIDs>
<PID1>
<PID2>
</PIDs>
<BingHits>
<YahooHits>
<Folder1Bytes>
<Folder1Files>
<Folder2Bytes>
<Folder2Files>
<ExTime>

Sequence match score
Identifier match score
Partial identifier match score
Match score
File was not compared -- no score
Beginning of line differences
End of line differences
Beginning of statement comparison
End of statements comparison
Beginning of comment comparison
End of comment comparison
Lines in file 1
Lines in file 2
Instruction/comment line
Beginning of instruction sequences
Instruction sequence
Instruction in sequence
End of instruction sequences
Beginning of identifiers
Identifiers
End of identifiers
Beginning of partial identifiers
Partial identifiers in file 1
Partial identifiers in file 2
End of partial identifiers
Number of hits on Bing search engine for preceding elements
Number of hits on Yahoo search engine for preceding elements
Total bytes in all files examined in folder 1
Total number of files examined in folder 1
Total bytes in all files examined in folder 2
Total number of files examined in folder 2
Time to execute program

Example DocMate database file
#Each line begins with a tag, ends with a newline
#Comments begin with #, end with a newline
<Program>DocMate
<Version>version
<Date>date
<Time>time
<CComment>Centered comment
<LComment>Left justified comment
<Folder1>input_folder
<Subs1>T
<Folder2>compare_folder
<Subs2>F
<FileType>filetypes
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<SameName>T
<FileThresh>number
#For each file in the first set of files being compared:
<Dir1>input_file_1_path_relative_to_Folder1
<Dir2>input_file_2_path_relative_to_Folder2
<File1>filename
<NumWords1>number_of_words
<Size1>size_in_bytes
<File2>filename
<NumWords2>number_of_words
<Size2>size_in_bytes
#Note: <Dir1> and <Dir2> tags may or may not be repeated if they are
unchanged from subsequent files
#Matching word sequences
<Sequences>
<InSeq>line_number line_number sequence_length_number
<Instr>Instruction 1
<Instr>Instruction 2
<Instr>Instruction 3
<Instr>Instruction n<InSeq>line_number line_number sequence_length_number
<InSeq>line_number line_number sequence_length_number
<InSeq>line_number line_number sequence_length_number
</Sequences>
<SequenceScore>sequence_correlation_score
# Note: If there is no sequence score there were no sequences to compare
# or sequences were not compared in this run.
#Matching words
<IDs>
<ID>identifier_string identifier_string identifier_string identifier_string
<BingHits>12 888 3 90023
<ID>identifier_string
<BingHits>129
</IDs>
#Partially matching words
<PIDs>
<PID1>partial_identifier_string partial_identifier_string
<PID1>partial_identifier_string partial_identifier_string
<PID1>partial_identifier_string
<PID2>partial_identifier_string partial_identifier_string
<PID2>partial_identifier_string partial_identifier_string
<PID2>partial_identifier_string
</PIDs>
<IdentifierScore>identifier_correlation_score
# Note: If there is no identifier score there were no identifiers to compare
# or identifier matching was not selected for this run.
<Score>file_pair_correlation_score
#For each uncompared file (a file that was never compared to anything):
<Dir1>input_file_1_path_relative_to_Folder1
<File1>filename
<NumLines1>number_of_lines
<Size1>size_in_bytes
<NoScore>
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#Summary
<Folder1Bytes>number
<Folder1Words>number
<Folder1Files>number
<Folder2Bytes>number
<Folder2Words>number
<Folder2Files>number
<ExTime>execution time
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Contacting SAFE Corporation

Software Analysis and Forensic Engineering Corporation
20863 Stevens Creek Blvd.
Suite 456
Cupertino, CA 95014
www.SAFE-corp.com
Tel. (408) 517-1167
Fax (408) 693-3727
Email: Support@SAFE-corp.com
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